主题更新:全面兼容WPML多语言插件,新增百度地图

上个月底我们发布了最新的Module主题,后续也陆续新增了2个不同的演示风格,并在近期又升级了一个新版本1.1,主要就是修复和完善了一些线上测试和用户反馈的问题建议。近几天我们又先后升级了之前的几款主题,升级的内容大部分是框架的共有功能,很多功能是在Module开发的时候就已经开发完成,在Module主题测试发布以后,才在本次正式同步更新到之前的wordpress主题

以下是本次更新的主要内容:

完美兼容WPML插件,实现多语言切换功能

WPML插件在之前的版本种我们就已经可以达到基本的兼容要求,正如WPML插件在兼容说明里面提到的,只要按照wordpress官方API标准开发,就基本上能够兼容。我们的主题开发严格遵守官方API标准开发,此次的更新可以使主题的设置信息也实现切换,达到完美兼容。

新增百度地图功能

地图功能是一直都有计划新增的功能,所以在Module主题开发的时候我们纳入了开发计划,并且融入到我们的Themer框架中作为我们的基础模块和组件,使用Themer框架的所有主题都将支持这个功能。

浏览器兼容提示

浏览器兼容提示是一个关系到用户体验的问题,如果没有这段提示,访客可能不明白为什么页面显示出现问题,对网站可能会产生负面印象。新加入的提示可以告知用户页面出现了兼容问题,并且提醒用户尽快升级浏览器。

PS:由于windows xp系统微软早已不再提供维护,windows 7系统一般最低都是IE9,所以我们将在IE8及以下版本的IE浏览器显示该提示。

第三方依赖资源更新

本次更新我们对于主题引用的一些资源也做了更新,bootstrap更新至3.3.7版本,FontAwesome图标库更新至4.7.0,Slider Revolution插件更新至5.3.1.5。

其他更新

除了上面这些更新,主题还更新了不少细节性的地方,以及一些显示上面的优化。

  1. 优化移动端字体和间距,更好的阅读体验;

  2. SEO功能短代码输出优化;

  3. 下拉菜单优化,鼠标移出延时150ms收回,避免鼠标快速移过导致的显示问题;

  4. 支持最新版wordpress(4.7+)文章模版选择功能,可以选择文章模版为新闻详情或者产品详情;

  5. 依赖插件安装工具升级;

  6. 针对非中文语言摘要长度的优化;

  7. PHP兼容优化;

  8. Themer框架优化升级;

  9. 细节样式优化

上一篇:WordPress 500错误怎么办?如何查看网站错误信息?

下一篇:2017年春节假期放假安排及售后服务说明

猜你喜欢

在线客服